Asus UX31A con Ubuntu 12.04

Publicado por Ramón en

Hace pocos días que por fin me he decantado por actualizar mi viejo portátil, que tras 5 años de uso y viajes entendía que ya merecía un relevo.

Tras valorar un montón de ultrabooks y encontrar una buena oferta por el modelo recién salido de Asus,  opté por el zenbook prime, más concretamente el modelo Asus Zenbook Prime UX31A-R5006, uno de los ultrabooks más recomendados, aunque con sus características más básicas (es lo que tiene la economía doméstica española).

Lo primero una buena y una mala-incomprensible noticia.  Al preguntar al servicio técnico de Asus sobre Linux, la respuesta escueta y muy frustrante:

“Estimado cliente,
Asus no dispone de controladores o soporte compatibles con Linux y este equipo.”

Increíble que una multinacional de las tecnologías, excluya de forma tan flagrante a una parte de los usuarios e imponga la esclavitud tecnológica como bandera, pero… es lo que nos queda soportar a los usuarios que pretendemos sentirnos libres.

Asus UX31A con Ubuntu 12.04Y la buena que si que se puede instalar Gnu/Linux en este ultraportátil, y más concretamente yo he probado con la distribución más conocida: Ubuntu 12.04.

Realmente no he descubierto nada ni he tenido que rebanarme mucho el cerebro, todo está aquí, aunque en “guiri”: https://help.ubuntu.com/community/AsusZenbookPrime.

Lástima que, una vez más, sea la Comunidad, mediante voluntariado la que realice el trabajo de las Corporaciones, que siguen con su visión cortoplacista de apoyar el Yugo Tecnológico.

Aunque el equipo con Ubuntu 12.04 funciona bastante veloz y cuasiperfecto, aún existen algunas funciones que no funcionan de teclas, así como algunas características muy concretas.  A diferencia de lo que dicen otros usuarios, a mí si que me funcionan casi todas las teclas de función, incluidas las de bajar o subir la luz del teclado, y la única que por el momento se resisten es subir y bajar brillo de la pantalla, pero… he de decir que no he probado ninguno de los scripts descritos en la página de ayuda de ubuntu.

Lo primero que debes hacer es descargarte una Ubuntu 64, si lo intentas con la versión de 32 bits se instalará sin problemas, pero… no te aparecerá en el menú de arranque, ya que no está preparada para las nuevas BIOs EFI.

Por si las moscas y si quieres mantener el disco duro tal y como venía de fábrica con su windows 7 home, que luego ya se sabe que son problemas de que si no te doy garantías, que si patatín y patatán, te recomiendo que uses clonezilla para clonar el disco duro.

Lo primero para poder usar un usb con clonezilla o con la instalación de Ubuntu es pulsar repetidamente la tecla ESC nada más arrancar el portátil, y te aparecerá las diferentes opciones de arranque de la BIOS.

Cuando comiences a instalar Ubuntu, actívale la opción que actualice mientras instalas, y así evitarás sustos de que no te arranque una vez instalada porque no está a la última.

Una vez que instales el ubuntu 64 en tu equipo, sin tener que toquetear mucho, ya te aparecerá el típico menú de arranque grub de elección de sistema operativo.  Eso si, al menos a mí, no me va el Windows si lo eligo en este menú de arranque, me dice que el EFI es inválido, pero… si por cualquier circunstancia quieres usarlo, no hay drama, simple, cuando enciendas el equipo dale repetidamente al ESC (como si quisieras arrancar de nuevo con el USB) y elegi EFI Windows, y ya podrás usar Win.

Seguro que es muy fácil tocar el EFI para que coexistan en un mismo EFI tanto Win como Ubuntu funcionado, pero como en mi caso no uso Windows, ¿para qué complicarme la vida?  y además, con el truquito que os he dicho, siempre lo tendré por si lo necesito en alguna ocasión para alguna de esas webs incompatibles o similares.

Por último, yo quise poner el último kernel, el 3.5.2, nada más sencillo:

  • cd /tmp
  • wget -O linux-kernel-3.5.2 http://dl.dropbox.com/u/47950494/upubuntu.com/linux-kernel-3.5.2
  • chmod +x linux-kernel-3.5.2
  • sudo sh linux-kernel-3.5.2

si no te arranca o funciona bien (en algunos arranques me da problemas la pantalla de inicio, que carga pero no aparece, hay que darle al INTRO), nada más sencillo que arrancar con el último kernel que te funcionó correcto, imagino que el 3.2.0-30, y eliminar el 3.5.2:

  • sudo apt-get purge linux-image-3.5.2-030502

Y ahora a compartir, ¿mejoras, trucos, consejos,…?

En este día...


Ramón

Apasionado del Conocimiento Libre y de las personas. Autor de Software Libre y Comunicación

17 commentarios

capira · 22/08/2012 a las 10:27 am

¿Qué especificaciones tiene el que te has comprado?

    ramonramon · 22/08/2012 a las 1:23 pm

    Aquí las llevas:
    Procesador Intel® Core™ i5-3317U
    Número de núcleos 2
    Hilos de proceso 4
    Velocidad / Frecuencia 1,7 GHz
    RAM 4 GB (1 x 4 GB en placa) DDR3 1600 MHz
    Disco Duro 128 GB SSD sATA3
    Tarjeta Gráfica Intel® HD Graphics 4000
    Memoria Gráfica Compartida
    Tamaño Pantalla 13,3″ (33,8 cm) retroiluminada LED
    Resolución 1600 x 900
    Lector Óptico No dispone
    Puertos USB 2 x USB 3.0
    Conexiones 1 x micro HDMI, 1 x mini VGA, audio, micrófono
    Conectividad Wireless 802.11 a/g/n; Bluetooth 4.0; Intel WiDi
    Lector de Tarjetas SD, SDHC, SDXC, MMC
    Teclado Retroiluminado, tipo chicle
    Webcam HD con micrófono
    Dimensiones 325 x 223 x 3 ~ 18 mm
    Peso 1,3 kg
    Altavoces Integrados Estéreo
    Audio Bang & Olufsen ICEpower®
    Batería / Autonomía 4 celdas / Hasta 8 horas

Venan Llona (@vllona) · 22/08/2012 a las 2:05 pm

Tengo dos preguntas, por qué la 12.04 y no una más “rodada”, estilo 10.04 como hacen algunas distribuciones? Por el EFI?
La segunda, probé una vez Clonezilla como propones, pero fui incapaz de hacerlo funcionar. ¿Qué tal un post con un “The Making Of…”?
Gracias por compartir.

    Ramón · 22/08/2012 a las 2:08 pm

    Gracias Venan, lo de la 12.04 es porque es la última estable, que además es LTS, y buscando así que tenga todos los drivers a la última, de hecho por eso me decanté también por instalar el último kernel linux, el 3.5.2
    Yo nunca había usado clonezilla, pero… inicialmente fue sencillo, eso sí, lo hice a nivel de disco a disco y copiando todos los sectores para así fuese lo más similar posible.
    Gracias como siempre a tí

      Venan Llona (@vllona) · 22/08/2012 a las 7:36 pm

      En ese caso, dejarías el disco sobre el que has copiado inutilizado por la copia, no? Por otro lado, me puedes dar una estimación del tiempo dedicado al clonado de disco? Gracias.

        Ramón · 24/08/2012 a las 9:11 am

        Pues no lo sé, aún no lo ví 😉

fugito · 22/08/2012 a las 11:56 pm

Yo tengo un netbook Asus, concretamente el Asus Eeepc 1011PX. En mi caso, he tenido la suerte de que asus si aporta soporte de drivers para este modelo y unos pocos mas de la misma serie.

A pesar de eso mi decepcion ha sido enterarme de que este modelo en otros paises se distribuye con Ubuntu 10.10 (por el año de salida de dicho modelo), pero que en España solo se distribuye con un dual boot de Windows 7 y otro sistema operativo linux bastante basico de arranque rapido.
Ademas, para mas inri, este netbook en España trae un sistema de arranque rapido que hace que no se muestre la pantalla de la BIOS al arranque del sistema, lo cual hace aun mas complicado la instalacion de otro sistema. Por suerte, buscando por internet encontre que pulsando F2 en el instante de arrancar el ordenador puedes acceder a la BIOS y desactivar el arranque rapido, y de esta manera poder instalar otro sistema facilmente.

Yo le he instalado un Debian hibrido stable/testing, manteniendo windows 7 para casos de necesidad, y me ha detectado todo el hardware de primeras sin necesidad de instalar nada a mano. Solo le faltan algunos detalles del touchpad, pero el resto funciona perfectamente

    ramonramon · 31/08/2012 a las 6:20 pm

    Gracias Fugito, lástima que Asus no apoye a los usuarios y se ponga del lado del yugo tecnológico, toda una pena para una multinacional informática de gran tamaño.

Mario · 31/08/2012 a las 10:56 pm

Hola Ramón,

Me alegro de tu post. ¿Podías comentar cuantas horas consigues con actividades normales (ofimática, webs, etcétera) en Ubuntu con ese modelo?

No es por presionar pero tengo una hora para decantarme 😉

Muchas gracias.

    Mario · 31/08/2012 a las 11:03 pm

    Me refería a horas de batería.

    1111 · 03/09/2012 a las 10:20 pm

    con el mío se logran unas 6 horas, grosso modo

      Ramón · 03/09/2012 a las 10:34 pm

      Gracias por tu aportación, no sabía que pudiera durar tanto. ¿Y qué tal satisfecho estás con él? Yo por el momento muy feliz, aunque apenas lo he usado.
      Saludos

Ramón · 31/08/2012 a las 11:43 pm

Hola Mario, aunque inicialmente me pareció rara la pregunta, luego entendí 😉
Pues si te soy sincero no tengo ni idea, pues no probé a usar la batería, ya que por el momento lo estoy usando en casa y siempre lo he tenido conectado a la electricidad. Así que, lo que te diga te engañaré.
Lo siento

Heiber Bustos · 15/10/2012 a las 6:51 am

Hola Ramon, gracias por el articulo me ha ayudado pues había instalado como 5 veces Ubuntu 12.04 y no me aparecía el menú de inicio, dos consultas:

Ahora que lo tengo instalado en mi zenbook UX32V, escucho que inicia el Ubuntu pero no tengo imagen en la pantalla, he tenido que cerrarlo y abrirlo varias veces para que retorne el vídeo. Qué me recomiendas?

Dos, este ultrabook tiene dos discos uno mecánico y otro de estado solido, el de estado solido tiene dos particiones una de 4G y otra de 25G, veo que no se esta usando, tiene algún propósito esto?

de nuevo gracias!

Heiber

    Ramón · 15/07/2013 a las 11:16 am

    Un placer Heiber, el problema en cuestión es que tu zenbook es de las típicas soluciones mixtas de ultrabaook económicos en los que mezclan dos discos duros, uno mecánico y otro sólido, que es una manera económica de acelerar el arranque y a la vez tener más disco duro. A cambio, además de que los datos están en un disco duro más lento, se consume más batería y se incrementa el peso. Desconozco si funciona igual que el mío que es 100% disco sólido, así como si la tarjeta gráfica es la misma, algo que puede está haciendo que te de fallos el video.
    Las dos particiones que indicas son las que generan los de Asus para las particiones de recuperación del Windows.
    Saludos

sinlios · 15/07/2013 a las 3:49 am

Hola, tengo tu mismo portátil y tengo un problema no tiene nada que ver con Linux, acabo de actualizar a la bios 219 y ahora no me arranca Windows me salta directamente a la bios, no se que hacer, te ha pasado algo raro al actualizar bios en este portátil???

    Ramón · 15/07/2013 a las 11:20 am

    Yo actualicé la BIOS sin problema alguno, ¿has mirado si al actualizar la BIOS se ha cambiado la opción por defecto de arranque (que existe como opción) y en lugar de que arranque el disco duro lo haga la BIOS?
    Dentro de la BIOS mira en el apartado tercero, que es boot, y que tendrás varias opciones de prioridades para arrancar
    Revisa las opciones y verás como se soluciona fácilmente.
    Saludos

Deja un comentario